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Your Comments 

Thermo Fisher Scientific is interested in receiving any comments 
you have regarding this manual.  

Comments should be sent to: 

sidinf.documentation@thermofisher.com 

mailto:sidinf.documentation@thermofisher.com�
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1. Welcome to GRAMS 
Envision 

GRAMS Envision is a multi-format instrument data viewer with 
the capacity to host plug-in processing and reporting modules. 

GRAMS Envision (hereafter referred to as ‘Envision’), enhances 
GRAMS Smart Convert technology to support the GAML 
(Generalized Analytical Markup Language) open standard XML 
instrument data format. This allows capture of comprehensive 
meta-data and simplifies communication with an increasing 
number of third party products. For more details on GAML, see 
the GAML website: 

http://www.gaml.org 

Designed from the outset to provide simple integration with 
external systems, Envision benefits from the Microsoft .NET 
development environment, with easily configurable menus, 
flexible screen architecture and an extensible modular design.  

Posting of appropriate data to the other products of the GRAMS 
Suite is achieved through simple mouse and menu options.  

The integral web browser allows seamless connectivity with 
enterprise data management portals and web based search tools. A 
comprehensive command line interface and enhanced ‘paste 
special’ function ensures simple interaction with desktop 
applications and electronic lab notebooks. 

Envision can invoke report methods created using the  
XML-based Blaise Inform design tool. Inform provides a 
comprehensive visual reporting tool for GRAMS Suite data and 
allows users to apply standardized reports to data originating from 
multiple instrument vendors.  

This manual guides you through the use of Envision. 

http://www.gaml.org/�
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Envision is supplied with a comprehensive set of instrument data 
file converters (the ‘GRAMS converters’), capable of translating a 
wide range of ‘foreign’ instrument data into the standard GAML 
format. This data can include industry standard formats (such as 
ASCII and AnDI/netCDF) as well as vendor-specific formats (for 
example, Thermo Scientific Atlas CDS and Agilent 
ChemStation). 

Conversion is triggered simply by opening a foreign data file in 
Envision. The Smart Convert logic is then responsible for 
identifying the file format and selecting the correct file converter. 

The file converters are supplied as a package that needs to be 
installed separately from the Envision application itself. For more 
details, see the Installing the GRAMS Converters chapter in the 
GRAMS Envision Installation Guide. 

Once installed, more details on the file converters can be found in 
the Instrument Data File Converters help system. To access this 
help system, select the ‘Instrument Help’ option from the 
Envision main menu’s Help sub-menu. 

Note The list of file converters that can be enabled on your 
system depends on the type of license that you have purchased. ▲ 

In addition to the formats handled by the file converters, 
Envision can read data in Agilent’s Analytical Instrument Markup 
Language (AnIML) format. 

Instrument Data File 
Converters 

Agilent AnIML 
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On a typical system, you can start the Envision application as 
follows: 

1. Either: 

• From the Windows Start menu, select  
All Programs/Thermo GRAMS Suite/Envision,   

OR 

• Double click on the Envision shortcut , on your 
Windows desktop or Quick Launch bar (if these shortcuts 
have been created). 

2. The next step depends on whether Envision has been set up 
with a valid license: 

• A valid license has been installed 

The Envision application starts up. See the Envision User 
Interface chapter for details on how to use Envision. 

• A valid license cannot be found 

A License Failure message is displayed: 

 

Figure 1-1. License Failure Message 

• Click OK to try and obtain an Envision license. 

The Request License window is displayed, allowing 
you to request a license. For more details on 

Starting Envision 
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requesting a license, see the Licensing Envision chapter 
of the GRAMS Envision Installation Guide. 

The Envision application also starts up, in Demo 
Mode. 

• Click Cancel to skip licensing instructions. 

The Envision application starts up, in Demo Mode. 

When Envision cannot find a valid license, it starts in Demo 
Mode. The HTML Viewer opens (as the default module) with 
the GAML website’s ‘Example GAML Files’ page loaded: 

 

Figure 1-2. Envision in Demo Mode 

This web page allows you to download example GAML files 
derived from a range of common instruments, which can then be 
viewed in Envision. 

When operating in Demo Mode, Envision only opens GAML, 
SPC and AnIML data files, and it will not save GAML data files. 
All the standard display capabilities remain available. 

Demo Mode 
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Envision is protected by the Macrovision FLEXnet security 
system. This encodes a license to a specific machine using a 
unique MAC address from one of its network adapters. 

Envision can use two types of licensing: 

• File-based — Envision checks a specified license file for valid 
license details. 

• Server-based — Envision queries a license server for valid 
license details.  

Server-based licensing requires a Thermo Licensing Server 
installation, either on your local PC or on a network PC. Refer to 
the Thermo Licensing Server user documentation. 

For more details on requesting an Envision license, see the 
Licensing Envision chapter of the GRAMS Envision Installation 
Guide. 

When you receive a new license (for example, if the previous one 
expires or you change your network adapter), you need to select it 
for use with Envision. 

To select a license: 

1. Start the Envision application, and select Help / About 
GRAMS Envision from the main menu. 

The About GRAMS Envision dialog box is displayed: 

 

Figure 1-3. About GRAMS Envision Dialog Box 

Licensing Envision 

Selecting an Envision 
License 
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2. Click on the Select New License button. 

The Select License dialog box is displayed: 

 

Figure 1-4. Select License Dialog Box 

Note If you have never selected a valid Envision license, this 
dialog box is also displayed when you start the Envision 
application. ▲ 

3. Specify either a valid license file, or a license server that has 
been set up with to use your Envision license. 

See the Specifying a License File and Specifying a License 
Server sections. 

4. Once you have specified your license file or server, click on 
the Select License dialog box’s OK button. 

Envision sets up the new license, and a ‘Successfully updated 
license file’ message is displayed. 

5. Click on the message’s OK button to return to the Envision 
application. 

The next time you start Envision, it will attempt to use the 
specified license file or server. 
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To specify a license file: 

1. In the Select License dialog box, select the ‘Specify License 
File’ option. 

2. If you have not already done so, save your license file to a 
suitable location, e.g. your Envision program folder. 

The license file will have the extension ‘.lic’, and will typically 
be named ‘Envision.lic’. 

3. Use the Browse button to specify the required license file. 

The file’s path and name are displayed in the ‘Choose the 
License File...’ field. 

4. Click on the Select License dialog box’s OK button. 

To specify a license server: 

1. In the Select License dialog box, select the ‘Specify License 
Server’ option. 

2. If you have not already done so, set up your license server to 
use your Envision license. 

You will typically need to copy a server-based Envision license 
file to your license server PC, and then set up its instance of 
the Thermo Licensing Server to use it. Refer to the Thermo 
Licensing Server user documentation. 

3. In the ‘Enter the Computer Name...’ field, enter the network 
name of your license server, e.g. ‘licenseserver01’. 

4. Click on the Select License dialog box’s OK button. 

Specifying a License File 

Specifying a License Server 
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 Notes 
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2. The Envision User Interface 

The Envision application’s user interface includes the following 
features:  

Main toolbar Main window

Main menu 

LegendWorkspace

Data Preview 
window

File Navigator

Status bar
 

Figure 2-1.  Envision User Interface 
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Feature Description 

Main 
menu 

Drop down menus allow access to the Envision 
functions. They can also be used to change the 
way in which items are displayed in the interface 
or to access the Envision help.  

See the Menus section for more details. 

Toolbars The toolbars provide quick access to Envision 
functions.  

See the Toolbars section for more details. 

File 
Navigator 

The File Navigator can be used to navigate 
through all open GAML files. Items are 
displayed in a tree hierarchy format.  

See the File Navigator section for more details. 

Data 
Preview 
window 

The integral Data Preview window, displayed 
below the File Navigator, provides a thumbnail 
view of the selected data element. This pane is 
displayed upon startup by default.  

See the Data Preview Window section for more 
details. 

Main 
window 

The Main window is displayed to the right hand 
side of the Envision interface.  

At startup, the Trace Browser, Parameter 
Browser and Peak Table Browser modules are 
loaded into the Main window. Each of these 
three modules is updated when the selection in 
the File Navigator changes.  

Additional modules such as the HTML Viewer, 
Linked Data Viewer and Report Viewer are 
opened as appropriate. 

See the Main Window section for more details. 
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Feature Description 

Legend The Legend is an integral part of the Trace 
Browser defining the spectra currently on 
display.  

See the Trace Browser section for more details. 

Workspace The Workspace displays a listing of all working 
data and data held for future use in the Holding 
Area.  

See the Workspace Pane section for more details. 

Status bar The status bar describes the currently active data 
item with text matching that used in the 
Workspace window.  

See the Status Bar section for more details. 
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The Envision interface displays two different menu types: 

• Main menu 

• Main Window menu. 

A description of the main menu follows. The Main Window 
menu options are described in the Main Window Menu section, 
later in this chapter. 

The Envision main menu is displayed at the top of the Envision 
interface. This menu can be used to open files, open additional 
tabbed pages, hide tabbed pages, manipulate toolbars and display 
options, and forward data to other GRAMS Suite applications. 

The main menu displays the following options: 

 

Figure 2-2.  Envision Main Menu 

Each menu option accesses a sub-menu of related options. A 
description of each of these menu options follows. 

The File menu displays the following options: 

 

Figure 2-3.  File Menu 

 

Menus 

Main Menu 

File Menu 
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Option Description 

Open Displays a standard Open dialog box, from 
which you can select the file that you want 
to open. 

Open HTML 
Viewer 

Opens a new HTML Viewer in the Main 
window. 

For more information about the HTML 
Viewer, refer to the HTML Viewer section 
of this chapter. 

Save As Select this option to save a GAML file. This 
option is only enabled if you have first 
selected a top level or parent node in the File 
Navigator or Workspace. 

Refer to the Using the Save As Option 
section in the File Navigator section of this 
chapter for more information. 

Close Closes the currently active GAML file. 

Close All Closes all open GAML files. 

Exit Exits and closes the Envision application. 
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The View menu displays the following options: 

 

Figure 2-4.  View Menu 

Option Description 

Trace Browser Shows / hides the Trace Browser. 

Refer to the Trace Browser section of this 
chapter for more information. 

Parameter 
Browser 

Shows / hides the Parameter Browser. 

Refer to the Parameter Browser section of 
this chapter for more information.  

Peak Table 
Browser 

Shows / hides the Peak Table Browser. 

Refer to the Peak Table Browser section of 
this chapter for more information. 

Trace Preview If this option is selected, the Data Preview 
window displays a data preview of the active 
element in the File Navigator in Trace 
Preview mode.  

Refer to the Data Preview Window section 
of this chapter for more information. 

View Menu 
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Option Description 

Property 
Preview 

If this option is selected, the Data Preview 
window displays a data preview of the active 
element in the File Navigator in Property 
Preview mode.  

Refer to the Data Preview Window section 
of this chapter for more information. 

Hide Preview Hides the Data Preview window. A check 
mark appears beside the menu option if the 
Data Preview window is currently hidden. 

Refer to the Data Preview Window section 
of this chapter for more information. 

Standard 
Toolbar 

Shows / hides the Standard toolbar. A check 
mark appears beside the toolbar name in the 
menu if it is currently displayed. 

Operations 
Toolbar 

Shows / hides the Operations toolbar. A 
check mark appears beside the toolbar name 
in the menu if it is currently displayed. 

Workspace Shows / hides the Workspace pane. 

Status Bar Shows / hides the status bar. A check mark 
appears beside the menu item if the status 
bar is currently displayed 

File Navigator Shows / hides the File Navigator. 
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The Display menu displays the following options: 

 

Figure 2-5.  Display Menu 

Option Description 

New Trace 
Viewer 

Opens a new instance of the Trace Viewer in 
the Main window. 

New 
Parameter 
Viewer 

Opens a new instance of the Parameter 
Viewer in the Main window. 

New Peak 
Table Viewer 

Opens a new instance of the Peak Table 
Viewer in the Main window. 

New Link 
Viewer 

Opens a new instance of the Linked Data 
Viewer in the Main window. 

GAML 3D 
Viewer 

Opens a new instance of the GAML 3D 
Viewer in the Main window. 

The Report menu displays a single Browse Report Method menu 
option. 

This option accesses the Report Viewer for creating reports from 
GAML data. For more information refer to the Report Viewer 
section of this chapter. 

Display Menu 

Report Menu 
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The Action menu displays the following options: 

 

Figure 2-6.  Action Menu 

The options on this menu can be used to send the active trace 
array or entire trace to the following applications: 

• GRAMS/AI 

• GRAMS/3D 

• Spectral ID.   

Note If a product is not installed, the related menu option will 
not be available. ▲ 

The data is sent as a temporary SPC file that is stored on disk and 
can then be opened with the appropriate application. 

If the active element is a trace with multiple trace arrays, a 
multifile is sent to GRAMS/AI or Spectral ID. If the active 
element is a trace array, the single trace array is sent to 
GRAMS/AI or Spectral ID. 

When sending data to GRAMS/3D, the entire trace (multifile) is 
sent regardless of whether the current element is a trace or trace 
array. 

Action Menu 
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The Tools menu displays the following options: 

Option Description 

Options Displays the Options dialog box, which 
allows to you to set a number of program 
options. 

Refer to the Setting the Envision Application 
Options section for more information. 

Save setting as 
default 

Saves all the current settings so that they are 
applied to each new Linked Data Viewer 
window. 

The options on this menu enable you to choose the way in which 
items are displayed in the Main window: 

 

Figure 2-7.  Window Menu 

Option Description 

Tabbed View Toggles the view in the Main window 
between tabbed and untabbed views. A 
check mark appears beside the menu item if 
Tabbed View is enabled. 

Tools Menu 

Window Menu 
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Option Description 

Cascade Displays open windows in the Main window 
in Cascade view. This option is only 
available if Tabbed View is disabled. 

Tile 
Horizontally 

Tiles all open windows in the Main window 
horizontally. This option is only available if 
Tabbed View is disabled. 

Tile Vertically Tiles all open windows in the Main window 
vertically. This option is only available if 
Tabbed View is disabled. 

Close Current 
Window 

Closes the window that currently displayed 
in the Main window. 

Close All 
Windows 

Closes all windows that are currently 
displayed in the Main window. 

The bottom of the Window menu displays a list of the windows 
that are currently open. For more information, refer to the Main 
Window section of this chapter. 

The options on the Help menu enable you to access the Envision 
help file or view details of the version of Envision that you are 
using: 

Option Description 

GRAMS 
Envision Help 

Accesses the Envision help file. 

Instrument 
Help 

Accesses the Instrument Data File 
Converters help file. 

This help file can only be accessed if the 
GRAMS Converters have been installed. 

Help Menu 
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Option Description 

About GRAMS 
Envision 

Accesses version and licensing details for 
your Envision application. 

This option also allows you to select 
another license, or request a new license. 
See this manual’s Welcome to GRAMS 
Envision chapter. 
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The Envision user interface displays the following toolbars by 
default: 

• Standard toolbar 

• Operations toolbar 

• Browser toolbars. 

Descriptions of the individual Browser toolbars can be found in 
the Trace Browser, Parameter Browser and Peak Table Browser 
sections of this chapter. 

The Standard toolbar displays the following buttons by default: 

Button Description 

 Open File Allows the user to open a GAML or 
SPC file from disk. 

 Open New 
HTML 
Viewer 

Opens a new HTML Viewer window. 

Refer to the HTML Viewer section of 
this chapter for more information. 

 Save As Click on this button to save a selected 
GAML file. This button is only 
enabled if you have first selected a top 
level or parent node in the File 
Navigator or Workspace. 

Refer to the Using the Save As Option 
section in the File Navigator section of 
this chapter for more information. 

 Close 
Current File 

Closes the currently active GAML. 

 Close All 
Files 

Closes all open GAML files. 

Toolbars 

Standard Toolbar 
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The Operations toolbar displays the following buttons by default: 

Button Description 

 Open in new 
Trace Viewer 
window 

Opens a new instance of the Trace 
Viewer.  

Refer to the Trace Browser section for 
more information. 

 Open in new 
Parameter 
viewer 
window 

Opens a new instance of the Parameter 
Viewer.  

Refer to the Parameter Browser section 
for more information.  

 Open in new 
Peak Table 
viewer 
window 

Opens a new instance of the Peak 
Table Viewer.  

Refer to the Peak Table Browser 
section for more information. 

 Open in new 
Link viewer 
window 

Opens a new instance of the Linked 
Data Viewer. 

Refer to the Linked Data Viewer 
section for more information. 

 Send Data to 
GRAMS/AI 

Sends the current trace / trace array to 
GRAMS/AI (as SPC). 

 Send Data to 
GRAMS/3D 

Sends the current trace to GRAMS/3D 
(as SPC). 

 Send Data to 
Spectral ID 

Sends the current trace / trace array to 
Spectral ID (as SPC). 

 Options Displays the Options dialog box, 
which allows you to set a number of 
program options.  

Refer to the Customizing the User 
Interface section for more information. 

Operations Toolbar 
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Button Description 

 GRAMS 
Envision 
Help 

Accesses the Envision help file. 

You can customize the Envision toolbars by adding or removing 
toolbar buttons as required. 

To add a button to a toolbar: 

1. Click on the  icon on the appropriate toolbar. 

2. Select Add or Remove Buttons from the pop-up menu that is 
displayed. 

A list of toolbar buttons is displayed: 

 

Figure 2-8.  Add/Remove Buttons Options 

A check mark appears beside each of the buttons that is 
currently displayed.  

Adding/Removing Toolbar 
Buttons 

Adding Toolbar Buttons 
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3. Select a button, or click on the Customize… option to open 
the Customize window: 

 

Figure 2-9.  Customize Window 

The Customize window can be used to add new toolbars and 
menu options (commands), or specify toolbar and menu 
options for the Envision user interface. 

To remove a button from a toolbar: 

1. Click on the  icon on the appropriate toolbar. 

2. Select Add or Remove Buttons from the pop-up menu that is 
displayed. 

A list of buttons is displayed. 

3. Select the button that you want to remove from the toolbar.  

Removing Toolbar Buttons 
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The status bar is displayed at the bottom of the Envision 
interface. It can be displayed or hidden by selecting View/Status 
Bar from the main menu. 

The status bar describes the currently active data item with text 
matching that used in the Workspace window. 

 

Figure 2-10.  Status Bar 

The status bar will also indicate whether the Parameter Viewer is 
in “Filter” or “Browse” mode by listing the number of parameters 
displayed as “X of Y rows”. 

 

Status Bar 
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The File Navigator pane is displayed to the left of the Envision 
user interface by default. It enables to you navigate through all 
open GAML files and preview the data in the browser modules. 

The File Navigator can be pinned/unpinned, resized, and closed 
as required. Refer to the Customizing the User Interface section 
for more information. 

 

Figure 2-11.  File Navigator 

The File Navigator enables you to navigate through all open 
GAML files, view the elements in the browser panes and send 
data to Envision modules. 

The tree-view represents each level of the GAML hierarchy as 
branch of the tree. Each level has a unique icon associated with it 
(the icon will also indicate if the data is linked). 

File Navigator 
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Clicking on the  or  buttons at each level expands or 
collapses the tree. Double-clicking on an element that has child 
elements toggles the expansion and collapsing of the element. 
The cursor keys may also be used to navigate the tree. 

Clicking on an element in the tree makes that element the active 
element. As each element is clicked the browser panes in the 
Main window are updated to reflect the relevant data for the 
element, and the element will be described in the status bar. Refer 
to the Main Window section for information about the browser 
panes. The Status Bar section describes the features of the status 
bar. 

The following icons are used to represent elements in the File 
Navigator pane: 

Icon Description 

 Root node of 
GAML file 

This node will always be present. The 
Parameter Browser will display details 
associated with the entire file. Always 
contains at least one experiment node. 

 Experiment 
node 

A single analyzed item and contains at 
least one trace node. The Parameter 
Browser will display details associated 
with the item. 

 Trace node Data taken from a single detector or 
data from several sources will be 
indicated by a single or multiple traces 
for the experiment.  The Parameter 
Browser will display details associated 
with the data. 

 Trace array 
node 

Represents a single 2D X,Y profile. 

Viewing the File 
Navigator Hierarchy 
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Icon Description 

 Peak table 
node 

Acts as the parent for the individual 
peaks in a trace array. Displays as a 
child to the trace array and can contain 
more than one peak. The Peak Table 
Browser will display information about 
each identifiable peak in the trace 
array. 

 Peak node The Parameter Browser will display 
details associated with the peak. 

 Linked view 
node 

A 3D display available when data 
produced by an instrument and the 
converter create a link between the two 
trace array types. 

Right clicking on an element in the File Navigator pane displays 
the following pop-up menu: 

 

Figure 2-12.  File Navigator RMB Menu 

File Navigator Pop-up 
Menu 
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Option Description 

Save As Select this option to save an appropriate 
node of a GAML file. 

Refer to the Using the Save As Option 
section for more information about using 
this option. 

Display Accesses the Display menu options. 

For more information, refer to the Main 
Menu section of this chapter. 

Report Accesses the Report menu options. 

For more information, refer to the Main 
Menu section of this chapter. 

Action Accesses the Action menu options. 

For more information, refer to the Main 
Menu section of this chapter. 

Send to 
Holding Area 

This option can be used to send data to the 
Holding Area. The Holding Area is 
described in the Workspace Pane section of 
this chapter. 

Close Closes the File Navigator pane. 

Items at the bottom of the menu indicate which Viewers are 
currently open.  

Note Some menu options may be grayed-out if they are not 
applicable to the item that is currently selected in the File 
Navigator. ▲ 
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The Save As menu option can be used to save any appropriate 
sub-node of a GAML file (i.e. one containing traces or trace 
arrays), as an SPC format binary file. 

When you select this option, a standard file Save As window is 
displayed for you to enter the file name and location. 

The Save As function may optionally be used to save GAML 
format XML files. 

Important The ability to save GAML format XML files is a 
separately licensed feature of Envision, which can be obtained 
by contacting Thermo Fisher Scientific Sales at: 

www.thermo.com/grams 

If the Save As feature is enabled for GAML format XML files on 
your system, the Save As menu option will be enabled when you 
select the top level (GAML file) node in the File Navigator or 
Workspace pane. 

Using the Save As Option 

http://www.thermo.com/grams
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The Data Preview window is displayed by default below the File 
Navigator: 

 

Figure 2-13.  File Navigator with Data Preview Window 

The Data Preview window allows you to preview the information 
for the item that is currently selected in the File Navigator pane.  

Data Preview 
Window 
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Information can be viewed in two different ways: 

• Trace Preview 

• Property Preview 

To change the display mode, either: 

• Right click on the Data Preview window and select the 
required option from the pop-up menu,  OR  

• Select the View option from the main menu then select the 
required viewing option. A check mark beside an item in the 
View menu indicates the current mode.   

Note When you start the Envision application the default view 
is Trace Preview. ▲ 

The Trace Preview display option shows the active element: 

 

Figure 2-14.  Trace Preview Mode 

The information that is displayed depends on the item that is 
currently selected in the File Navigator: 

• When a GAML or Experiment is selected, the Data Preview 
window will display the message “<Preview not available>”. 

• When a trace is selected, the Data Preview window shows the 
first trace array of the trace. 

Trace Preview Display 
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• When a trace array is selected, the Data Preview window 
shows the trace array data as a 2D trace (either continuous or 
discrete pulses). 

• When a peak table is selected, the display window shows the 
peak table’s trace array data as a 2D trace. The peak will be 
labeled as indicated in the File Navigator. 

• When a peak is selected, the display window shows the peak’s 
trace array data as a 2D trace. Only that peak is displayed and 
will be labeled as indicated in the File Navigator. 

• When a linked view is selected, the display window shows the 
parent trace data as a 2D trace (either continuous or discrete 
pulses). 

The Property Preview display option shows the properties of the 
item that is currently selected in the File Navigator. Information 
can include the specific values of elements and attributes as well 
as some derived properties. The information displayed differs 
according to the element type. If an element, attribute, or other 
property does not apply, it will not be displayed. 

Note You can also view this information when viewing the 
Parameter Browser by selecting the File/Element Properties 
option from the Main Window menu. For more information 
refer to the Parameter Browser section. ▲ 

 

Figure 2-15.  Property Preview Mode 

Property Preview Display 
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To hide the Data Preview window either: 

• Click the right mouse button in the appropriate window and 
select Hide Preview from the pop-up menu that is displayed,  
OR  

• Select View/Hide Preview from the main menu.   

To redisplay the Data/Property Preview window, select a preview 
mode from the View menu. 

Hiding the Data Preview 
Window 
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The Main window displays the pages used for viewing, processing 
and reporting data. These pages fall into two specific categories: 

• Browsers 

• Viewers 

The difference between the two page types is that the Browser 
pages are updated each time you highlight a new GAML file in 
the Navigator; whereas a Viewer page will keep the image of the 
GAML file that you sent to it.  

When the Envision application starts, the Main window displays 
three Browser pages: 

• Trace Browser — this is a modified version of the Trace 
Viewer that displays the trace of the selected item in the File 
Navigator pane. This window will never contain more than 
one trace. Refer to the Trace Browser section for more 
information. 

• Parameter Browser — this is a modified version of the 
Parameter Viewer that displays the parameters, derived 
properties, and element and attribute values of the selected 
item in the File Navigator. Refer to the Parameter Browser 
section for more information. 

• Peak Table Browser — a modified version of the Peak Table 
Viewer that displays peak table elements and attributes as well 
as peak parameters of the selected item in the File Navigator.  
Refer to the Peak Table Browser section for more 
information. 

You can use the navigation icons  in the upper right corner 
of the Main window to navigate through the tabbed pages and/or 
close unnecessary views. 

Main Window  
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You can view a list of all windows that are currently open in the 
Main window by selecting the Window option from the main 
menu. Open windows are displayed at the bottom of the 
Window menu, as shown in the following example: 

 

Figure 2-16.  Window Menu with Example List of Open Windows 

All open browsers are shown at the top of the list. All open views 
are suffixed with a number indicating the order in which the view 
was opened. 

Note The exception to this is the HTML Viewer, where the 
initial view opens without a numeric prefix. Any subsequent 
HTML views that are opened will show a numeric prefix. ▲ 

Selecting an item from this list will switch the display in the Main 
window to the selected view. 

The individual tabbed pages can be closed or redisplayed by 
selecting View from the main menu then selecting or deselecting 
the appropriate option. 
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There are several viewing modes for the Main window: 

• Tabbed View — this is the default view for the Main 
window. Clicking on a tab makes the corresponding module 
active and brings it into focus. 

• Cascade — this viewing mode arranges the windows in a 
cascading, stacked view 

• Tile Horizontally — this viewing mode arranges the windows 
in a horizontal array. 

• Tile Vertically — this viewing mode arranges the windows in 
a vertical array. 

Note If Tabbed View is enabled, all other viewing options are 
disabled. ▲ 

When in Tabbed View mode, clicking on one of the tabs in the 
Main window will bring the selected item to the foreground. To 
close a window in Tabbed View mode, click on a window’s tab to 
make sure it is the current window, then click on the  in the 
top right-hand corner of the Main window. 

To change the display mode: 

1. Select the Window option from the main menu. 

2. Select the required display mode from the Window menu. 

Viewing Modes 

Changing the Display Mode 
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The Main Window menu displays across the top of the Main 
window: 

 

Figure 2-17.  Main Window Menu 

The functions that are performed by the options on the Main 
Window menu differ according to the currently selected view. 
For a description of the functions that are available, refer to the 
individual sections of this chapter that describe the view options. 

The toolbar at the top of the Main window is used to access 
functions for the currently selected view. For a description of the 
functions that are available, refer to the sections of this chapter 
that describe the individual view options. 

Main Window Menu 

Main Window Toolbar 
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The Trace Browser is a viewing window which displays 2D views 
of a trace. Opening a new GAML file or right-clicking on a Trace 
or Trace Array element in the File Navigator pane will open the 
Trace Browser. 

 

Figure 2-18.  Trace Browser 

The features of the Trace Browser are the same as those for the 
Trace Viewer, so they will only be described once in this chapter. 

Trace Browser 
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This section describes the menu options at the top of the Trace 
Browser pane. 

The File menu for the Trace Browser displays the following 
options: 

 

Figure 2-19.  Trace Browser — File Menu 

Option Description 

Remove 
Current Trace 

Removes the selected trace from the Trace 
Browser pane and the Legend. 

Remove All 
Traces 

Removes all traces from the Trace Browser 
pane and the Legend. 

Page Setup Displays a standard Page Setup dialog box, 
which can be used to adjust the page settings 
prior to printing.  

Print Preview Displays a standard Print Preview pane, 
which enables you to view a preview of a 
trace prior to printing. 

Print Sends the current trace to the printer. A 
standard Print dialog box is displayed, from 
which you can select the printer. 

Close Closes the Trace Browser 

Trace Browser Menus 

File Menu  



 The Envision User Interface 

Thermo Fisher Scientific GRAMS Envision User Guide      41 

The Edit menu for the Trace Browser displays the following 
options: 

 

Figure 2-20.  Trace Browser — Edit Menu 

Option Description 

Undo Last 
Zoom 

This option can be used to undo the last 
zoom or autoscale operation. 

Copy Copies the currently selected data to the 
clipboard. 

The View Menu for the Trace Browser displays standard options 
for hiding or displaying toolbars and the Legend: 

 

Figure 2-21.  Trace Browser — View Menu 

Edit Menu 

View Menu 
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The Display menu for the Trace Browser displays the following 
options: 

 

Figure 2-22.  Trace Browser — Display Menu 

Note The Zoom and Autoscale features will affect the display of 
all loaded data if the display is set to either the Stacked or 
Overlaid mode. ▲ 

Option Description 

Autoscale Rescales the display such that the data points 
and peak labels fit into the display 
completely. 

Autoscale – X 
only 

Rescales the display such that the x axis fits 
into the display completely. 

Autoscale – Y 
only 

Rescales the display such that the y axis and 
peak labels fit into the display completely. 

Zoom In Rescales the display to zoom in 10% around 
the current cursor position (whether or not 
the cursor is actually displayed). 

Display Menu 
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Option Description 

Zoom Out Rescales the display to zoom out 10% 
around the current cursor position (whether 
or not the cursor is actually displayed). 

Set Display 
Limits 

Opens the Set Limits dialog box, which 
enables you to specify the displays limits for 
the X and Y axes. 

Refer to the Setting the Trace Display Limits 
section for more information. 

Display Mode Used to select the display mode. The 
following options are available: 

• Paged — shows only one trace array in 
the Trace Browser. 

• Overlaid — overlays all open trace arrays 
in the Trace Browser. 

• Stacked — shows all open trace arrays 
stacked in the Trace Browser. 

Refer to the Viewing Multiple Traces in a 
Window section for more information. 

Reverse X axis 
orientation 

Flips (reverses) the X axis orientation. By 
default all low values are displayed to the 
left, with high values to the right. This 
orientation can be saved as the default if 
required. 

Normalize Y Normalizes the Y data points from 0 to 1. 

When you select this option a warning 
message is displayed to advise you that peak 
label information cannot be shown in 
normalized displayed. If you choose to 
continue, peak labeling will be turned off. 
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Option Description 

Peak Labels Displays a sub-menu with the following 
options: 

 

Figure 2-23.  Peak Labels Sub-menu 

Select the required option to change the 
peak labels. The default option is “Default”. 

Refer to the Trace View Peak Labeling 
section for more information. 

Active Trace Displays a sub-menu with the following 
options: 

 

Figure 2-24.  Active Trace Sub-menu 

Options on this menu can be used to 
navigate to another data point, change the 
properties of the active trace or add  
user-defined labels to the active trace. 
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The Tools menu for the Trace Browser displays the following 
options: 

 

Figure 2-25.  Trace Browser — Tools Menu 

Option Description 

Options Opens the Trace Viewer Options window. 
Refer to the Setting the Trace Display 
Options section for more information. 

Save Current 
Settings as 
Default 

Saves the current settings so that they are 
applied to each new Linked Data Viewer 
window. 

The Help menu for the Trace Browser displays the following 
options: 

 

Figure 2-26.  Trace Browser — Help Menu 

Option Description 

Trace Viewer 
Help 

Accesses the Trace Viewer section of the 
Envision help. 

About Trace 
Viewer 

Displays the licensing information for the 
Trace Viewer. 

Tools Menu 

Help Menu 
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The Trace Browser pane displays two toolbars: 

• Standard Toolbar 

• Display Toolbar 

The buttons on these toolbars provide standard navigation 
features and easy access to Trace Browser/Trace Viewer menu 
options. 

These toolbars can be hidden by right mouse clicking in the 
toolbar area at the top of the Trace Browser pane and selecting 
the required option from the pop-up menu that is displayed. 

The Standard toolbar contains the following buttons by default: 

Button Description 

 Remove 
Current 
Trace 

Removes the selected trace from the 
display and the Legend. 

 Remove All 
Traces 

Removes all traces from the Trace 
Browser pane and the Legend. 

 Print Opens a standard Print dialog box, 
which can be used to select the printer 
to which the trace will be sent. 

Trace Browser Toolbars 

Standard Toolbar 
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The Display toolbar contains the following buttons by default: 

Button Description 

 Autoscale Rescales the display so that the data 
points and peak labels fit into the 
display completely. 

 Autoscale – X 
only 

Rescales the display such that the x axis 
fits into the display completely. 

 Autoscale – Y 
only 

Rescales the display such that the y axis 
and peak labels fit into the display 
completely. 

 Zoom In Rescales the display to zoom in 10% 
around the current cursor position 
(whether or not the cursor is actually 
displayed). 

 Zoom Out Rescales the display to zoom out 10% 
around the current cursor position 
(whether or not the cursor is actually 
displayed). 

 Undo last 
zoom 

Returns to the previous screen. This 
action may be repeated to go back 
several screens. 

 Paged 
(display 
mode) 

Shows only one trace array in the 
Trace Browser. 

Refer to the Viewing Multiple Traces 
in a Window section for more 
information. 

 Overlaid 
(display 
mode) 

Overlays all open trace arrays in the 
Trace Browser. 

Refer to the Viewing Multiple Traces 
in a Window section for more 
information. 

Display Toolbar 



The Envision User Interface 

48      GRAMS Envision User Guide Thermo Fisher Scientific 

Button Description 

 Stacked 
(display 
mode) 

Shows all open trace arrays stacked in 
the Trace Browser. 

Refer to the Viewing Multiple Traces 
in a Window section for more 
information. 

 Reverse X axis 
orientation 

Flips (reverses) the X axis orientation. 
By default all low values are displayed 
to the left, with high values to the 
right. This orientation can be saved as 
the default if required. 

 Normalize Y Normalizes the Y data points from 0 to 
1. 

When you select this option a warning 
message is displayed to advise you that 
peak label information cannot be 
shown in normalized displayed. If you 
choose to continue, peak labeling will 
be turned off. 

 Go to the 
next data 
point 

Navigates to the next data point, to the 
right of the current cursor position. 

 Go to the 
Previous data 
point 

Navigates to the previous data point, 
to the left of the current cursor 
position. 

Note The Zoom and Autoscale features will affect the display of 
all loaded data if the display is set to either the stacked or overlaid 
mode. ▲ 
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Clicking with the right mouse button in the Trace Browser pane 
displays a pop-up menu with the following options: 

 

Figure 2-27.  Trace Browser Pop-up Menu 

The options on this menu have already been described in the 
Trace Browser Menus and Trace Browser Toolbars sections of 
this chapter. 

The trace display limits can be set manually if required.  

To set the trace display limits manually: 

1. Select Display/Set Display Limits from the Trace Browser 
menu. 

The Set Limits dialog box is displayed: 

 

Figure 2-28.  Set Limits Dialog Box 

2. Enter the beginning and ending X and Y display limits then 
click on the OK button to save the changes. 

Trace Browser Pop-up 
Menu 

Setting the Trace Display 
Limits 
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Selecting a display mode from the Display sub-menu allows you 
to view multiple traces from one trace window. The Envision 
application will automatically assign a line color to each trace in 
the display.  

The following display options are available: 

• Paged display mode ( ) shows only one trace array in the 
trace display at a time, even if multiple traces are open. You 
can page through all traces sequentially by using the arrow 
keys. 

• Overlaid display mode ( ) overlays all open trace arrays in 
the trace box. Some traces may not be seen if they are outside 
the currently set X and Y limits. 

• Stacked display mode ( ) shows all open trace arrays 
stacked in the trace box. The trace box is divided vertically 
into equally sized regions with each trace array in a separate 
region. 

By default, peak labels are set to “Default” - meaning that the 
display is consistent with the text displayed in the File Navigator. 
The Display/Peak Labels menu option allows you to select the 
text type to define the peak labels by placing a checkmark to 
indicate selection. 

Note If no peak table and peaks have been defined in the trace 
array, the Peak Tables sub-menu will show [Empty]. ▲ 

Peaks are marked with a label and indicator line connecting the 
label to the peak position. 

• Peak labels are displayed with vertical orientation. 

• Peak baselines are displayed as black lines with small vertical 
bars at each endpoint 

Viewing Multiple Traces 
in a Window 

Trace View Peak 
Labeling 
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If there are multiple traces for a single trace array, the first trace 
will be used to the mark peaks, by default. You can change the 
trace by selecting a new table definition from the Display/Peak 
Labels sub-menu, or from the Trace Browser’s right mouse 
button pop-up menu. There is one entry per peak table with a 
check mark beside the one used. 

Note This menu item will change for each active trace array. It 
will be dimmed out when no peak tables are associated with the 
active trace array. ▲ 

You can set trace display options, such as showing crosshairs and 
partition lines, and active trace settings such as line properties. 

To change the trace display options select Tools/Options from 
the Trace Browser menu. The Trace Viewer Options window is 
displayed:  

 

Figure 2-29.  Trace Viewer Options Window 

Setting the Trace Display 
Options 
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The Display Settings section displays the following options: 

Option Description 

Show cursor 
crosshairs 

When this option is selected, the cursor 
crosshairs are displayed on the trace display 
at the position of the last mouse click. The X 
and Y values of the mouse click position are 
indicated by the intersection of the 
crosshairs, and are labeled on the appropriate 
axis.  

Double-clicking on any point in the trace 
display makes the cursor crosshairs move to 
the data point closest to the mouse click. 

Show 
partition lines 
in stacked 
mode 

When this option is selected, a black 
partition line appears at the lowest Y value in 
each trace array’s section in the stack. 

Show peak 
warning for 
normalized Y 
mode 

When this option is selected, a warning 
dialog is displayed that indicates that peak 
labels and indicators will not be displayed in 
normalized mode. 

Note The Display Settings options are selected by default. 
Deselect the check boxes to turn the settings OFF. ▲ 

The Active Trace Settings section displays the following options: 

Option Description 

Automatic 
scaling when 
the active trace 
changes 

If this option is selected, the display 
autoscales in the X and Y directions each 
time the active trace changes. This option is 
deselected by default. 
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Option Description 

Automatic X 
axis 
orientation 
when the 
active trace 
changes 

Selecting this option causes the display to 
automatically orient the trace based upon the 
axis unit of the active trace. This option is 
deselected by default. 

Show Active 
Trace using 
specified line 
properties 

Selecting this option causes the active trace 
array to be displayed with a specific line 
color/style/width. Clicking on the  
Line Properties button opens the Line 
Properties dialog box: 

 

Figure 2-30.  Line Properties Dialog Box 

From here you can change the line color, 
style, and width of the active trace. The 
Preview section displays a preview of the line 
style for the current trace. Click on the OK 
button to save the changes. 

The Line Properties window can also be 
opened from the Display/Active Trace/Line 
Properties menu option.  

Note For the active trace display to use 
your defined line properties, the Show Active 
Trace using specified line properties check 
box must be selected in the Trace Viewer 
Options window. ▲ 



The Envision User Interface 

54      GRAMS Envision User Guide Thermo Fisher Scientific 

The label applied to a trace can be changed using the Edit User 
Label dialog box. 

To change the trace display labels: 

1. Select the Display/Active Trace option from the Trace 
Browser menu.  

The Edit User Label dialog box is displayed: 

 

Figure 2-31.  Edit User Label dialog 

2. Enter the name that will appear in the Legend for the active 
trace.  

3. Click on the OK button to save the changes.  

The Legend displays below the Trace Browser pane. It describes 
all trace arrays that are currently loaded. As long as there is a trace 
array in use, there will always be one and only one active trace 
array. Right-clicking on an element in the Legend will open a 
pop-up menu accessing select trace functions. 

Note The Legend can be pinned/unpinned, resized, or closed as 
required. Refer to the section, Customizing the User Interface for 
detail. ▲ 

Changing the Trace 
Display Labels 

Legend 
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The Parameter Browser displays parameters, derived properties, 
and element and attribute values for any element in the GAML 
hierarchy. When there are no parameters for that element, the 
Parameter Browser will appear blank (any previously displayed 
data is cleared when new data is loaded). 

 

Figure 2-32.  Parameter Browser 

The data grid displays data in the following columns: 

• Name (hidden by default) 

• Alias (hidden by default) 

• Label  

• Value 

• Group 

Each column in the grid can be toggled on or off by selecting the 
corresponding item in the Parameter Browser’s View sub-menu.  

You can also toggle columns from the Parameter Browser’s pop-
up menu, which is shown when you right-click on the data grid. 

Parameter Browser 
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The pop-up menu also includes a Close option, which closes the 
Parameter Browser. 

The features of the Parameter Browser are the same as those for 
the Parameter Viewer, so they will only be described once in this 
chapter. 

This section describes the menu options at the top of the 
Parameter Browser pane. 

The File menu for the Parameter Browser displays the following 
options: 

 

Figure 2-33.  Parameter Browser — File Menu 

Option Description 

Export current 
table to file 

Exports the currently displayed table 
(including hidden columns) to a tab 
delimited text file. A standard file Save 
dialog box is displayed. 

Export current 
table to 
clipboard 

Exports the currently displayed table 
(including hidden columns) to a tab 
delimited text file. A standard file Save 
dialog box is displayed. 

Export all 
parameters to 
file 

Exports all parameters (including hidden 
columns) to a tab delimited text file. A 
standard file Save dialog box is displayed. 

Parameter Browser Menu 

File Menu  
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Option Description 

Element 
Properties 

Displays the properties of the current 
elements. These properties include the 
specific values of elements and attributes as 
well as some derived properties.  

Close Closes the Parameter Browser 

The Edit menu for the Parameter Browser displays the following 
option: 

 

Figure 2-34.  Parameter Browser — Edit Menu 

Option Description 

Copy Copies the currently selected data to the 
clipboard. 

The View Menu for the Parameter Browser displays standard 
options for hiding or displaying columns and toolbars: 

 

Figure 2-35.  Parameter Browser — View Menu 

Edit Menu 

View Menu 
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The Display menu for the Parameter Browser displays the 
following options: 

 

Figure 2-36.  Parameter Browser — Display Menu 

Option Description 

Apply Filter Used to set parameter filters to display 
specified data points. Refer to the Filtering 
Parameters section for more information. 

Remove Filter Removes the applied filter. 

The Tools menu for the Parameter Browser displays the following 
option: 

 

Figure 2-37.  Parameter Browser — Tools Menu 

Option Description 

Save Current 
Settings as 
Default 

Saves the current settings so that they are 
applied to each new Linked Data Viewer 
window. 

Display Menu 

Tools Menu 
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The Help menu for the Parameter Browser displays the following 
options: 

 

Figure 2-38.  Parameter Browser — Help Menu 

Option Description 

Parameter 
Viewer Help 

Accesses the Parameter Viewer section of the 
Envision help. 

About 
Parameter 
Viewer 

Displays the current version of the Parameter 
Viewer. 

The Parameter Browser toolbar contains the following buttons by 
default: 

Button Description 

 Export 
current table 
to specified 
file 

Exports the currently displayed table 
(including hidden columns) to a tab 
delimited text file. A standard file Save 
As dialog box is displayed. 

 Apply 
Filter… 

Used to set parameter filters to display 
specified data points. Refer to the 
Filtering Data section for more 
information. 

 Remove Filter Removes the applied filter. 

Help Menu 

Parameter Browser 
Toolbar 
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When viewing items in the Parameter and Peak Table Browsers 
you can apply filters to display specific data points.  

To apply a filter: 

1. Click on the Apply Filter button  on the Parameter 
Browser toolbar, or select Display/Apply Filter from the 
Parameter Browser menu. 

The Filter dialog box is displayed: 

 

Figure 2-39.  Filter Dialog Box 

By default, the Filter dialog box displays information about 
the currently active cell. 

2. Select a column from the Column drop down list.  

This is the column to which the filter will be applied. The list 
displays all the current display columns. 

3. Select the required operator from the Operation drop down 
list. 

The list displays the following options:  

• Contains (default)  

• Equals 

• Does not contain 

• Does not equal. 

Filtering Data 
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4. Enter a value in the Text field. Any valid text string can be 
entered in this field. 

5. Click on the OK button to apply the filter to the displayed 
data. 

When you apply a filter to the data, the Display/Remove Filter 

menu item is enabled and the Remove Filter button  is 
activated. Selecting either the Remove Filter menu option or 
clicking on the Remove Filter button removes the filter and 
returns the display to browse mode. 

You can sort the data in the Parameter Browser grid into 
ascending or descending order by clicking on the column 
headings. An arrow displayed to the right of a column heading 
indicates the column used for the sort, and the order of the sort. 

 

Figure 2-40.  Sorted Column Example 

Removing a Filter 

Sorting Data 
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The Peak Table Browser displays information about the Peak 
Table element of a GAML file. Opening a new GAML file or 
right-clicking on an element in the File Navigator will open a 
Peak Table Browser. 

 

Figure 2-41.  Peak Table Browser — Peak Table View 

The data grid can be displayed in the following ways:  

• Peak Table View (default) 

• Peak Parameters View 

• Peak Table Parameters View.  

The  icon can be used to track a row through the 3 views of the 
Peak Table Module. 

Note Refer to the Peak Table Browser Display Options section 
for more information. ▲ 

Peak Table Browser 
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Columns in the Peak Table Browser grid can be hidden or 
displayed by selecting/deselecting the appropriate column names 
in the View sub-menu. Refer to the View Menu section for more 
information. 

Alternatively, you can right click on the grid to show/hide 
columns. A check mark appears beside the displayed columns.  

Note The default setting is all columns displayed in Peak Table 
View and all columns, except Name, shown in the Peak 
Parameter and Peak Table Parameter Views. It will also list the 
number of peaks (or parameters) displayed as “X of Y peaks 
displayed” (“X of Y parameters displayed”). ▲ 

The features of the Peak Table Browser are the same as those for 
the Peak Table Viewer, so they will only be described once in this 
chapter. 

This section describes the menu options at the top of the Peak 
Table Browser pane. 

The File menu for the Peak Table Browser displays the following 
options: 

 

Figure 2-42.  Peak Table Browser — File Menu 

Option Description 

Export current 
table to file 

Exports the currently displayed table 
(including hidden columns) to a tab 
delimited text file. A standard file Save 
dialog box is displayed. 

Peak Table Browser 
Menu 

File Menu  
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Option Description 

Export current 
table to 
clipboard 

Exports the currently displayed table 
(including hidden columns) to a tab 
delimited text file. A standard file Save 
dialog box is displayed. 

Close Closes the Peak Table Browser. 

The Edit menu for the Peak Table Browser displays the following 
option: 

 

Figure 2-43.  Peak Table Browser — Edit Menu 

Option Description 

Copy Copies the active trace box, together with 
the trace array data, to the clipboard. 

Edit Menu 
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The View Menu for the Peak Table Browser displays the 
following options: 

 

Figure 2-44.  Peak Table Browser — View Menu 

Option Description 

Peak Table This is the default mode for the Peak Table 
Browser. The grid displays element and 
attribute values for each peak in the peak 
table. All available columns will display. 

Refer to the Peak Table Browser Display 
Options section for more information. 

View Menu 
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Option Description 

Peak Table 
Parameters 

In Peak Table Parameter view, the grid 
displays the following columns:  

• Name (hidden by default) 

• Label 

• Value 

• Group 

Parameters from the peak table element are 
displayed. 

Refer to the Peak Table Browser Display 
Options section for more information. 

Peak 
Parameters 

In Peak Parameter view, the grid can show 
peak parameters from a single peak or all 
peaks. The grid contains the following 
columns:  

• Peak Number 

• Name (hidden by default) 

• Label 

• Value 

• Group 

Refer to the Peak Table Browser Display 
Options section for more information. 
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The Display menu for the Peak Table Browser displays the 
following options: 

 

Figure 2-45.  Peak Table Browser — Display Menu 

Option Description 

Apply Filter Used to set parameter filters to display 
specified data points. Refer to the Filtering 
Data section for more information. 

Remove Filter Removes the applied filter. 

The Tools menu for the Peak Table Browser displays the 
following option: 

 

Figure 2-46.  Peak Table Browser — Tools Menu 

Option Description 

Save Current 
Settings as 
Default 

Saves the current settings so that they are 
applied to each new Linked Data Viewer 
window. 

Display Menu 

Tools Menu 
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The Help menu for the Peak Table Browser displays the 
following options: 

 

Figure 2-47.  Peak Table Browser — Help Menu 

Option Description 

Peak Table 
Viewer Help 

Accesses the Peak Table Viewer section of 
the Envision help. 

About Peak 
Table Viewer 

Displays the current version of the Peak 
Table Viewer. 

The Peak Table Browser toolbar contains the following buttons 
by default: 

Button Description 

 Export 
current table 
to specified 
file 

Exports the currently displayed table 
(including hidden columns) to a tab 
delimited text file. A standard file Save 
As dialog box is displayed. 

 Apply 
Filter… 

Used to set parameter filters to display 
specified data points. Refer to the 
Filtering Data section for more 
information. 

 Remove Filter Removes the applied filter. 

 Peak Table Displays the Peak Table view. Refer to 
the Peak Table View section for more 
information. 

Help Menu 

Peak Table Browser 
Toolbar 
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Button Description 

 Peak Table 
Parameters 

Displays the Peak Table Parameters 
view. Refer to the Peak Table 
Parameters View section for more 
information. 

 Peak 
Parameters 

Displays the Peak Parameters view. 
Refer to the Peak Parameters View 
section for more information. 

The Peak Table Browser has three different display modes: 

• Peak Table 

• Peak Table Parameters 

• Peak Parameters 

A description of each of these options follows.  

Peak Table view is the default mode for the Peak Table Browser. 
The grid displays element and attribute values for each peak in 
the peak table. All available columns will display: 

• Peak Number 

• Peak Name 

• Peak X Value 

• Peak Y Value 

• Group 

• Baseline Start X 

• Baseline Start Y 

• Baseline End X 

Peak Table Browser 
Display Options 

Peak Table View 
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• Baseline End Y 

 

Figure 2-48.  Peak Table Browser — Peak Table View 

Clicking on the  /  icon to the left of each row 
expands/collapses the peak providing a hyperlink to its 
parameters. 

 

Figure 2-49.  Expanded Peak 

Clicking on the hyperlink opens the Peak Parameters view for the 
peak and displays the associated parameters. The parent row will 
display the information from that peak’s row in the peak table, 
with the column heading appended with a colon, followed by the 
value from the cell for that column. Clicking on the Back button 
will return the display to Peak Table view. 
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In Peak Table Parameters view, the grid displays the following 
columns:  

• Name (hidden by default) 

• Label 

• Value 

• Group 

 

Figure 2-50.  Peak Table Viewer — Peak Table Parameters 
View 

Parameters from the peak table element are displayed. 

Peak Table Parameters View 
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In Peak Parameters view, the grid can show peak parameters from 
a single peak or all peaks. The grid contains the following 
columns:  

• Peak Number 

• Name (hidden by default) 

• Label 

• Value 

• Group 

 

Figure 2-51.  Peak Table Viewer — Peak Parameters View 

When the Peak Parameter view is opened from the View menu or 
the toolbar button, parameter information for all peaks is 
displayed. This allows data comparison from multiple peaks. 
When opened via the Peak Parameters hyperlink, see Figure 2-49, 
only parameters from that single peak are displayed. 

You can sort the data in the grid into ascending or descending 
order. For more information refer to the Sorting Data section. 

Peak Parameters View 
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As mentioned previously, the Main window opens with three 
default Browser windows. All additional views are labeled 
“Viewer” and are suffixed with a number indicating the order in 
which the view was opened. 

Note The exception to this is the HTML Viewer, where the 
initial view opens without a numeric prefix. Any subsequent 
HTML views that are opened will show a numeric prefix. ▲ 

To open a new view: 

1. Select an element in the File Navigator. 

2. Click the right mouse button. 

3. Select the Display option from the pop-up menu that is 
displayed. 

4. Select the required viewer from the Display menu 

Alternatively, select the Display option from the main menu then 
select a view from the Display menu options. 

Note Some of the menu options may be grayed out if the 
selected element does not contain data that corresponds with the 
selected display type. ▲ 

 

Opening Additional 
Views 
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The HTML Viewer allows you to open URLs and retrieve files 
from a web-based application or search tool.  

To display the HTML Viewer either: 

• Click on the HTML Viewer button, , on the Main 
toolbar at the top of the Envision interface,  OR 

• Select File/Open HTML Viewer from the Main menu. 

The default home page is opened in a new HTML viewer 
window: 

 

Figure 2-52.  HTML Viewer 

The HTML Viewer’s Address field allows you to enter URLs 
directly: 

 

Figure 2-53.  HTML Viewer — Address Field 

HTML Viewer 
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Opening URLs in the HTML Viewer can be automated using the 
command line of Envision (see Appendix A). This facility can be 
used to allow a program, such as a LIMS system, to open a URL 
and pass parameters to a web application. The web application 
can then provide links to a file which can be selected, downloaded 
and viewed directly in Envision. 

For information about specifying the default home page, refer to 
the Setting the Envision Application Options section. 

Note The HTML Viewer is also shown when Envision starts in 
Demo Mode. ▲ 

This section describes the menu options at the top of the HTML 
Viewer. 

The File menu for the HTML Viewer displays the following 
options: 

 

Figure 2-54.  HTML Viewer — File Menu 

Option Description 

Open Displays the Enter URL dialog box, in 
which you can enter or browse for a URL.  

Print Sends the web page to the printer. A 
standard Print dialog box is displayed, from 
which you can select the printer. 

HTML Viewer Menu 

File Menu  
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Option Description 

Print Preview Displays a standard Print Preview pane, 
which enables you to view a preview of a 
web page prior to printing. 

Close Closes the HTML Viewer. 

The View menu for the HTML Viewer displays a single Toolbar 
menu option. This option can be used to hide or redisplay the 
HTML Viewer toolbar. 

The Help menu for the HTML Viewer displays the following 
options: 

 

Figure 2-55.  HTML Viewer — Help Menu 

Option Description 

HTML 
Viewer Help 

Accesses the HTML Viewer section of the 
Envision help. 

About HTML 
Viewer 

Displays the current version of the HTML 
Viewer. 

View Menu  

Help Menu 
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The HTML Viewer toolbar contains the following buttons by 
default: 

Button Description 

 Back Click on this button to navigate to the 
previous web page. 

 Forward Click on this button to return to the 
next web page. 

 Refresh Refreshes the current page. 

 Print Opens a standard Print dialog box, 
which can be used to select the printer 
to which the web page will be sent. 

 Print 
preview 
document 

Displays a standard Print Preview 
pane, which enables you to view a 
preview of the web page prior to 
printing. 

 Address Shows the address of the current URL. 

 Go Navigates to the specified URL 
address. 

 Close Closes the HTML Viewer. 

 

HTML Viewer Toolbar 
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This module utilizes the “link” element within a GAML file to 
show related (linked) traces in meaningful way. The viewer 
supports data such as GC-MS, LC-MS, and GC-IR: 

 

Figure 2-56.  Linked Data Viewer 

To display the Linked Data Viewer select Display/New Link 
Viewer from the main menu. 

The linked data module receives a “parent” trace and then looks 
for a “child” trace with a corresponding link indicator. This data 
is displayed in two trace boxes: 

• The parent trace is displayed in the top trace box. 

• The child trace is displayed in the lower trace box. 

Only one trace box can be considered the “active” trace box at 
any given time. Any actions performed apply to this trace box. 

Note The child trace must be within the same experiment as 
the parent. ▲ 

Linked Data Viewer 
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Each trace box is labeled with text indicating the trace array that 
is displayed, and matches the text from the Workspace. The 
traces are autoscaled independently when loaded. 

The trace boxes can be resized in the vertical direction to change 
the proportion of window space that each occupies by 
manipulating the splitter ( ) between them. 

Double clicking on any part of the trace box of the parent trace 
will also display the appropriate trace array of the child trace. The 
axis labels will correspond to the X and Y data Label attributes for 
the displayed traces. If a label does not exist, the unit attribute 
will be used. 

This section describes the menu options at the top of the Linked 
Data Viewer. 

The File menu for the Linked Data Viewer displays the following 
options: 

 

Figure 2-57.  Linked Data Viewer — File Menu 

Option Description 

Page Setup Displays a standard Page Setup dialog box, 
which can be used to adjust the page settings 
prior to printing. 

Print Preview Displays a standard Print Preview pane, 
which enables you to view a preview of a 
data prior to printing. 

Linked Data Viewer Menu 

File Menu  
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Option Description 

Print Sends the current data to the printer. A 
standard Print dialog box is displayed, from 
which you can select the printer. 

Close Closes the Linked Data Viewer. 

The Edit menu for the Linked Data Viewer displays the following 
options: 

 

Figure 2-58.  Linked Data Viewer — Edit Menu 

Option Description 

Undo Last 
Zoom 

This option can be used to undo the last 
zoom or autoscale operation. 

Copy Copies the currently selected data to the 
clipboard. 

The View menu for the Linked Data Viewer displays a single 
Toolbar option which can be used to hide or display the Linked 
Data Viewer toolbar. 

Edit Menu 

View Menu 
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The Display menu for the Linked Data Viewer displays the 
following options: 

 

Figure 2-59.  Linked Data Viewer — Display Menu 

Option Description 

Autoscale Rescales the display such that the data points 
and peak labels fit into the display 
completely. 

Autoscale – X 
only 

Rescales the display such that the x axis fits 
into the display completely. 

Autoscale – Y 
only 

Rescales the display such that the y axis and 
peak labels fit into the display completely. 

Zoom In Rescales the display to zoom in 10% around 
the current cursor position (whether or not 
the cursor is actually displayed). 

Zoom Out Rescales the display to zoom out 10% 
around the current cursor position (whether 
or not the cursor is actually displayed). 

Display Menu 
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Option Description 

Set Display 
Limits 

Opens the Set Limits dialog box, which 
enables you to specify the displays limits for 
the X and Y axes. 

Refer to the Setting the Trace Display Limits 
section for more information. 

Reverse X axis 
orientation 

Flips (reverses) the X axis orientation. By 
default all low values are displayed to the 
left, with high values to the right. This 
orientation can be saved as the default if 
required. 

Peak Labels Displays a sub-menu with the following 
options: 

 

Figure 2-60.  Peak Labels Sub-menu 

Select the required option to change the 
peak labels. The default option is “Default”. 

Refer to the Trace View Peak Labeling 
section for more information. 

Go to 
Previous data 
point 

Navigates to the previous data point. This 
option enables you to navigate through the 
data points of the active trace. 

The function is the same as if you double 
clicked near the data point to the immediate 
left of the current cursor position. 
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Option Description 

Go to Next 
data point 

Navigates to the next data point. This option 
enables you to navigate through the data 
points of the active trace. 

The function is the same as if you double 
clicked near the data point to the immediate 
right of the current cursor position. 

Peak Table Selecting this menu option allows you to 
choose from available peak tables for a trace 
array. Each peak table is listed with its name 
attribute (or the default string used in the 
File Navigator). A check mark indicates the 
selection made. By default, the first peak 
table is selected. This menu item will change 
for each active trace array and may be grayed 
out if there are no peak tables associated with 
the active trace array. 

The Tools menu for the Linked Data Viewer displays the 
following options: 

 

Figure 2-61.  Linked Data Viewer — Tools Menu 

Option Description 

Options Opens the Linked Data Viewer Options 
window. Refer to the Setting the Linked 
Data Viewer Options section for more 
information. 

Save Current 
Settings as 
Default 

Saves the current settings so that they are 
applied to each new Linked Data Viewer 
window. 

Tools Menu 
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The Help menu for the Linked Data Viewer displays the 
following options: 

 

Figure 2-62.  Linked Data Viewer — Help Menu 

Option Description 

Linked Data 
Viewer Help 

Accesses the Linked Data Viewer section of 
the Envision help. 

About Linked 
Data Viewer 

Displays the current version of the Linked 
Data Viewer. 

The Linked Data Viewer toolbar contains the following buttons 
by default: 

Button Description 

 Autoscale Rescales the display such that the data 
points and peak labels fit into the 
display completely. 

 Autoscale – X 
only 

Rescales the display such that the x axis 
fits into the display completely. 

 Autoscale – Y 
only 

Rescales the display such that the y axis 
and peak labels fit into the display 
completely. 

 Zoom In Rescales the display to zoom in 10% 
around the current cursor position 
(whether or not the cursor is actually 
displayed). 

 Zoom Out Rescales the display to zoom out 10% 
around the current cursor position 
(whether or not the cursor is actually 
displayed). 

Help Menu 

Linked Data Viewer 
Toolbar 
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Button Description 

 Undo last 
zoom 

Returns to the previous screen. This 
action may be repeated to go back 
several screens. 

 Reverse X axis 
orientation 

Flips (reverses) the X axis orientation. 
By default all low values are displayed 
to the left, with high values to the 
right. This orientation can be saved as 
the default if required. 

 Go to the 
next data 
point 

Navigates to the next data point, to the 
right of the current cursor position. 

 Go to the 
Previous data 
point 

Navigates to the previous data point, 
to the left of the current cursor 
position. 

By default, peak labels are set to “Default” - meaning that the 
display is consistent with the text displayed in the File Navigator. 
The Display/Peak Labels menu option allows you to select the 
text type to define the peak labels by placing a checkmark to 
indicate selection. 

Note If no peak table and peaks have been defined in the trace 
array, the Peak Tables sub-menu will show [Empty]. ▲ 

Peaks are marked with a label and indicator line connecting the 
label to the peak position. 

• Peak labels are displayed with vertical orientation. 

• Peak baselines are displayed as black lines with small vertical 
bars at each endpoint 

Linked Data View Peak 
Labeling 
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If there are multiple traces for a single trace array, the first trace 
will be used to the mark peaks, by default. You can change the 
trace by selecting a new table definition from the Display/Peak 
Labels sub-menu, or from the Linked Data Viewer’s right mouse 
button pop-up menu. There is one entry per peak table with a 
check mark beside the one used. 

Note This menu item will change for each active trace array. It 
will be dimmed out when no peak tables are associated with the 
active trace array. ▲ 

The display options for the Linked Data Viewer can be changed 
if required.  

To set the display options select Tools/Options from the Linked 
Data Viewer menu. The Linked Data Viewer Options dialog box 
is displayed: 

 

Figure 2-63.  Linked Data Viewer Options Dialog 

The following options are selected by default: 

• Show cursor crosshairs — when this option is selected, the 
crosshairs will display at the position of the last mouse click 
for the trace. The X and Y values will label the appropriate 
axis. Double-clicking on any point in the trace causes the 
crosshairs to move to the data point closest to the mouse 
click. 

Setting the Linked Data 
Viewer Options 
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• Automatic X axis orientation when trace changes — when 
this option is selected, the trace box will automatically orient 
the X axis based upon the default orientation of the axis unit 
of the active trace. 
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The Report Viewer can invoke report methods created using the 
XML-based Blaise Inform reporting system.  

 

Figure 2-64.  Report Viewer 

Blaise Inform is a drag and drop reporting system that can be 
used with GRAMS Suite data. Coupled with the Smart Convert 
facility of Envison, it allows you to apply standardized reports to 
data originating from multiple instrument vendors.  

Blaise Inform Report Designer is a visual tool for setting up these 
reports, which can be purchased on-line. For details see: 

http://www.thermoscientific.com/grams 

Report Viewer 

http://www.thermoscientific.com/grams
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To access the Report Viewer: 

1. Do one of the following: 

• Select Report/Browse Report Method from the main 
menu. 

• Click the right mouse button in the File Navigator pane 
and select Report/Browse Report Method from the File 
Navigator’s right mouse button menu. 

• Click the right mouse button on the Holding Area icon 
or on an individual item in the Holding Area and select 
Browse Report Method from the pop-up menu. This 
option can be used to send multiple GAML files to a 
single report template. The Holding Area is described in 
detail in the Holding Area section of this chapter.  

2. A standard Open dialog box is displayed: 

 

Figure 2-65.  Open Dialog Box   

The Open dialog box displays a list of available template 
‘.irm’ (Inform Report Method) files. 
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3. Select the report method and click on the Open button. 

You can also select method files from the Most Recently Used 
list, which is displayed when you select the Report option 
from the main menu. To add a report to this list you must 
open it once. 

 

Figure 2-66.  Report Menu —  Most Recently Used List 

The Report Viewer toolbar displays the following buttons and 
features by default: 

Button Description 

 Opens a standard Print dialog box. 

 Copy Copies the current page of the report 
to the Windows clipboard. 

 First page Navigates to the first page of the 
report. 

 Previous 
page 

Navigates to the previous page of the 
report. 

 Next page Navigates to the next page of the 
report. 

 Last page Navigates to the last page of the report. 

 Shows the current page number and 
the total number of pages in the report. 

Report Viewer Toolbar 



 The Envision User Interface 

Thermo Fisher Scientific GRAMS Envision User Guide      91 

Button Description 

 Zoom In Increases the size of the display. You 
can also zoom in by double-clicking 
the left mouse button when the cursor 
is positioned in the Report Viewer. 

 Zoom Out Reduces the size of the display. 

 

Drop down list, used to select the 
display size. 

 Closes the Report Viewer. 

You can drag a new GAML file onto the Report Viewer window 
to re-execute the report method with new data. 

The following images show examples of different Report Viewer 
displays: 

 

Figure 2-67.  Report Viewer —  Example Multiplot   

Viewing New Data 
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Figure 2-68.  Report Window —  Example Raman  

 

Figure 2-69.  Report Window —  NMR Data  
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The GAML 3D Viewer provides a 3-dimensional view of a 3D 
trace. You can choose different display and surface styles,  

To open the GAML 3D Viewer, select the Display/GAML 3D 
Viewer option from the main menu. In the File Navigator, you 
must have a trace node selected that contains 3D data. 

By default, the GAML 3D Viewer shows a surface plot of the 
selected data: 

 

Figure 2-70.  GAML 3D Viewer 

Note This viewer is an example of Envision’s extensibility. It is 
a plug-in that hosts a simple OCX control, which is capable of 
receiving data as defined in \plugins\plugins.xml (under the 
Envision installation folder). A Software Developer’s Kit for the 
definition of Envision plug-ins is available on application to 
Thermo Fisher Scientific. ▲ 

GAML 3D Viewer 
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You can select the following display styles from the GAML 3D 
Viewer’s Display Style menu: 

• Contour map as lines 

• Contour map filled colors 

• 3D surface plot (default) 

When in 3D surface plot mode, you can change the style of the 
plot using the Surface Style menu. 

This display style shows the trace as an X-Y ‘contour map’, with 
boundaries between values represented using colored lines: 

 

Figure 2-71.  GAML 3D Viewer — Contour Map as Lines 

Clicking on a point in the viewer displays ‘cross-hairs’, 
highlighting the exact X and Y values for that point. 

You can also click-and-drag on an area of interest to create a 
rectangular selection. Clicking within this selection zooms into it. 

GAML 3D Viewer Menu 

Contour Map as Lines 
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This display style is similar to ‘Contour map as lines’, but with 
colored fills rather than just lines: 

 

Figure 2-72.  GAML 3D Viewer — Contour Map Filled Colors 

Clicking on a point in the viewer displays ‘cross-hairs’, 
highlighting the exact X and Y values for that point. 

You can also click-and-drag on an area of interest to create a 
rectangular selection. Clicking within this selection zooms into it. 

Contour Map Filled Colors 
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This display style shows a 3-dimensional rendering of the trace, 
with X, Y and Z axes included: 

 

Figure 2-73.  GAML 3D Viewer — 3D Surface Plot 

With the mouse pointer over the central area of the viewer, it 
changes to a cross, . You can click-and-drag to zoom and/or 
rotate the plot (moving the mouse up/down zooms in/out, while 
moving it left/right will rotate left/right). Axes will be updated 
accordingly. 

With the mouse pointer near the edges of the viewer, it changes 
to an arrow,  /  /  / . If you click near an edge, the display 
scrolls towards that edge. 

You can change the style of the 3D surface plot using the Surface 
Style menu, which contains several different ways of displaying its 
data.  

For example, using ‘Show contour-level color bands’ makes it 
easier to see transitions between data ranges, while ‘Draws only 
vertex points’ shows only the actual data points recorded in the 
trace. 

3D Surface Plot 

Surface Styles 
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The Workspace pane is displayed by default at the bottom of the 
Envision user interface. It displays the currently “active” data. 
Elements or sub-elements may be displayed in the Workspace 
pane; depending on the Browser or Viewer to which the data has 
been sent.  

Each open Browser or Viewer has a separate entry in the 
Workspace list. When new data is added, the list expands to 
reflect any changes. 

 

Figure 2-74.  Workspace Pane 

The icon preceding an element’s description indicates the 
element type. The textual description matches the text displayed 
in the File Navigator for that element. 

Data is displayed in the Workspace pane after it has been opened 
in a viewer, processor, reporting tool, or dragged to the Holding 
Area. 

Workspace Pane 
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The Holding Area is a reservoir of data for future use and always 
appears as the first entry in the Workspace list. The Holding Area 
can be populated by: 

• Dragging items from the File Navigator pane; by highlighting 
the item and holding the left mouse button. 

• By right mouse clicking on an item in the File Navigator pane 
and selecting Send to Holding Area from the pop-up menu 
that is displayed. 

• Closing a window, such as a Parameter Viewer; in which case 
the contained node is moved to the Holding Area.  This 
behavior is controlled via the Workspace Settings on the 
Options window. For more information about the Options 
window refer to the Setting the Envision Application Options 
section of this chapter.  

The Holding Area can be used to group items together for 
reporting purposes. This enables you to send multiple GAML 
files to a single report template. 

To send multiple items to a report template: 

1. Move the items to the Holding Area, using one of the 
methods detailed previously. 

2. Click the right mouse button on the Holding Area icon in the 
Workspace pane, . 

3. Select Report\Browse Report Method from the pop-up menu 
that is displayed. 

4. Select the report method from the list displayed. 

For more information about reporting, refer to the Report Viewer 
section of this chapter. 

Holding Area 
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Right-clicking on an element in the Workspace displays a pop-up 
menu with the following options: 

 

Figure 2-75.  Workspace RMB Menu 

The options that can be accessed from this menu will vary 
according to the item that is currently selected in the Workspace 
pane. 

Option Description 

Save As Select this option to save an appropriate 
node of a GAML file. 

Refer to the Using the Save As Option 
section in the File Navigator section of this 
chapter for more information. 

Display Accesses the Display menu options. 

For more information, refer to the Main 
Menu section of this chapter. 

Report Accesses the Report menu options. 

For more information, refer to the Main 
Menu section of this chapter. 

Action Accesses the Action menu options. 

For more information, refer to the Main 
Menu section of this chapter. 

Workspace Menu Options 
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Option Description 

Remove from 
Holding Area 

This option can be used to remove a single 
item from the Holding Area. 

Note Closing a GAML file will also 
automatically remove it from the Holding 
Area. ▲ 

Empty 
Holding Area 

This option can be used to empty the 
Holding Area. This removes all items that 
are currently displayed in the Holding Area. 

Close Closes the file that is currently selected in the 
Workspace pane. 

Options on this menu can be used to access the Display, Report 
and Action menus. The Empty Holding Area menu option 
removes any unused items from the Holding Area. 

The Workspace pane can be pinned/unpinned, resized, and 
closed as required. Refer to the Customizing the User Interface 
section for more information. 
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This section describes how the appearance of the Envision user 
interface can be customized to suit your individual needs. 

You can show or hide any of the features that are currently 
displayed by: 

• Selecting or deselecting an item from the View option on the 
main menu. For any feature currently in view, a check mark 
will display next to the menu item. If a feature is currently 
hidden, no check mark will be displayed. 

• Elements can also be closed by clicking the  icon displayed 
in the upper right corner of each pane. 

The elements of the Envision interface can also be resized, by 
clicking on the upper and lower, and/or left and right edges of the 
window.  

To resize a pane, drag the  and  resizing buttons to move the 
borders to the desired position. 

The following elements of the Envision application may be 
floating, docked, or unpinned: 

• File Navigator 

• Data Preview pane 

• Workspace 

• Legend 

Click on the  icon to “unpin” a window or pane. The 
unpinned item is replaced by a tab on the application window, as 
shown in the following example: 

 

Figure 2-76.  Workspace — Unpinned 

Customizing the User 
Interface 

Hiding/Displaying 
Features  

Maximizing the Viewing 
Area 
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Clicking the mouse pointer on the tab will open the pane for 
viewing. Clicking the  icon will re-pin the element to its 
original location in the Envision application window. 

Dragging the title bar of a window causes it to ‘float’ above the 
main window. The window can remain floating or be dragged to 
a new position indicated by the blue and white docking icons, as 
shown in the following example: 

 

Figure 2-77.  Envision Windows — Docking Icons 
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You can set a number of different options for the Envision 
application. These options are accessed from the Options 
window. 

To open the Options window, select Tools/Options from the 
main menu. 

 

Figure 2-78.  Options Window 

The Options window is divided into four areas. 

The options in this area control whether Envision will be the 
default viewer for its supported file types: 

• ‘Set Envision as the default viewer for AnIML files’ check 
box. 

Select this check box if you want to make Envision your 
default viewer for AnIML data files, when you click on the 
Register… button. 

Setting the Envision 
Application Options 

Register Application 
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• Register… button. 

Click on this button to register Envision as the default viewer 
for GAML files and, if the ‘Set Envision…’ check box is 
selected, AnIML files. 

•  ‘Prompt users to register the application when it is not 
already registered’ check box. 

If selected, and if Envision is not currently registered as the 
default viewer for GAML files, the user will be prompted at 
startup to register Envision as the default viewer for GAML 
files. 

This area contains an ‘Add data to holding area when viewers 
close’ check box. If selected, a reference to a GAML entity will be 
retained in the Workspace’s ‘Holding Area’ when a window 
containing the GAML entity is closed. 

Note Closing the GAML entity entirely removes it from the 
Holding Area. ▲ 

This area contains a Home page field, which specifies the default 
URL to be opened each time the HTML Viewer is invoked. 

Note When Envision is running in Demo Mode, the home 
page is restricted to the GAML website’s ‘Example GAML Files’ 
page. ▲ 

This area contains a ‘Warn users of integrity test failures’ check 
box. If selected, users will be warned when a file does not match 
its internal checksum. This can indicate unauthorized alteration 
of a file. 

Workspace Settings 

HTML Viewer 

GAML Integrity 
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A. Command Line Syntax 

The following commands are designed to provide a basic 
automation interface to enable Envision to interact with external 
programs and web services. A more comprehensive plug-in SDK 
(Software Developer’s Kit) is available from Thermo Fisher 
Scientific. 

Note The syntax used for subsequent versions of Envision may 
be subject to change based upon client feedback. ▲ 

Command Line 
Arguments 

Description 

-wType 
<windowtype> 

The window to open. Valid window 
types are: 

• GamlView2D   

• GamlParam   

• GamlPeakParm  

• GamlViewLink   

• GamlReportViewer 

• GRAMS 

• GRAMS3D 

• HtmlViewer 

• SPECID 
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Command Line 
Arguments 

Description 

-wNew Flag that indicates to create a new 
window. 

If flag is absent, Envision will attempt to 
use an existing window. If a window of 
the appropriate window type is not 
already open, Envision will open a new 
window. 

-wName <window 
name> 

The window name that will be used to 
identify the window. It cannot be used to 
change the names of the three Browser 
windows. 

-r <report 
method list> 

For the GamlReportViewer window type 
option only. This flag indicates the 
Inform method report to use. One or 
more report methods are accepted when 
surrounded by quotes and files separated 
by a comma.  

Example: 

-r "c:\report1.irm, c:\report2.irm" 

The –r command argument is required 
option for the GamlReportViewer 
window type. It will be ignored by any 
other window type. 

When generating reports, if multiple 
GAML files (or RAW files) and multiple 
Report Methods are provided, each 
report method will be executed on each 
of the provided GAML files. Each of 
these reports will be displayed in its own 
Report Viewer window. 
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Command Line 
Arguments 

Description 

-f <file list> The GAML or RAW file to open. One or 
more files are accepted when surrounded 
by quotes and separated by commas.  

Example:   

-f "c:\data1.gaml, data2.gaml" 

-u <URL> URL to open. One or more URLs are 
accepted when surrounded by quotes and 
separated by commas.  

Example:   

-u "http://www.gaml.org, 
http://www.gaml2.org" 

The –u command argument is required 
for the HTMLViewer window type.   

Multiple URLs, when supplied, will open 
sequentially in a single HTML Viewer 
window with the most recent URL 
visible. You can view all the URLs using 
the ‘Back’ button. 
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Following are some command-line syntax examples: 

To open a single GAML file in the 2D viewer: 

Envision.exe -wType GamlView2D -wNew -wName "My Trace" -f 
"C:\data1.gaml" 

To create a report in a new window: 

Envision.exe -wType GamlReportViewer -wNew -wName "My Report" 
-r "c:\methods\mymethod.irm", -f "c:\data\file1.gaml, 
c:\data\file2.gaml" 

 

Examples 
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